[GRASS-de] problems compiling GRASS on SuSE 8.2

Marco Lechner marco.lechner at geographie.uni-freiburg.de
Do Feb 3 14:23:47 CET 2005

Hi list,

After hours of compiling with different options I still get this
error-message after starting GRASS and having chosen the mapset/location:

GRASS 6.0.0beta1:/usr/local/grass60/bin > Error in startup script: ps.map:
error while loading shared libraries: libgdal.so.1: cannot open shared
object file: No such file or directory
    while executing
"exec ps.map -p"
    (procedure "DmPrint::init" line 14)
    invoked from within
    (procedure "main" line 31)
    invoked from within
"main $argc $argv"
    (file "/usr/local/grass60//grass-6.0.0beta1/etc/dm/d.m.tcl" line 890)

but libgdal.so.1 is in /usr/local/gdal/lib/
libgdal.la        libgdal.so        libgdal.so.1      libgdal.so.1.6.0

gdal-config seems to be correct:

CONFIG_LIBS="-L/usr/local/gdal/lib -lgdal"
CONFIG_DEP_LIBS="-L/usr/local/lib -lgeos -lodbc -ljpeg -lpng -lz -lm -ldl -L
/lib -lpq "

A few more hints:

I tried compilation with the GRASS 6.0.0beta1 and the CVS-Snapshot from Jan
25th. with the follwoing options:

 ./configure --with-cxx --with-odbc --with-blas --with-blas-libs=/usr/lib/ -
-with-lapack --with-motif --with-readline  --with-freetype=yes --with-freety
pe-includes=/usr/include/freetype2 --with-mysql --with-mysql-includes=/usr/i
nclude/mysql/ --with-nls --with-gdal=/usr/local/gdal/bin/gdal-config --with-
postgres-includes=/usr/include/pgsql --with-postgres-libs=/lib/ --with-proj-
includes=/usr/local/proj/include/ --with-proj-libs=/usr/local/proj/lib/ --wi
th-glw --with-glw-libs=/usr/local/lib --with-glw-includes=/usr/local/include
 --enable-64bit --prefix=/usr/local/grass60./configure --prefix=/usr/local/g
rass60/ --with-postgres-includes=/usr/include/pgsql/

configure works:

GRASS is now configured for:  i686-pc-linux-gnu

 Source directory:            /nfs/u1/software/grass/grass-6.0.0beta1
 Build directory:             /nfs/u1/software/grass/grass-6.0.0beta1
 Installation directory:      /usr/local/grass60/grass-6.0.0beta1
 Startup script in directory: ${exec_prefix}/bin
 C compiler:                  gcc -g -O2
 C++ compiler:                c++ -g -O2
 FORTRAN compiler:
 Building shared libraries:   yes

  NVIZ:                       yes

  X11 support:                yes
  JPEG support:               yes
  TIFF support:               yes
  PNG support:                yes
  Tcl/Tk support:             yes
  PostgreSQL support:         yes
  MySQL support:              yes
  OpenGL(R) support:          yes
  ODBC support:               yes
  FFTW support:               yes
  BLAS support:               yes
  LAPACK support:             yes
  Motif support:              yes
  FreeType support:           yes
  GLw support:                yes
  NLS support:                yes
  Readline support:           yes
  C++ support:                yes
  openDWG support:            no
  GDAL support:               yes
  OGR support:                yes

make has first problems in GRASS_SRC/lib/proj:

GRASS GIS compilation log
Started compilation: Thu Feb  3 14:00:52 CET 2005
Errors in:
Finished compilation: Thu Feb  3 14:08:56 CET 2005

make in ...lib/proj says (no idea):

saone:/u1/software/grass/grass-6.0.0beta1/lib/proj # make
install -m 644 datum.csv gdal_datum.csv projop_wparm.csv ellipsoid.csv
pcs.csv stateplane.csv gcs.csv prime_meridian.csv unit_of_measure.csv

if I start make again it works without errors:

GRASS GIS compilation log
Started compilation: Thu Feb  3 14:17:34 CET 2005
Errors in:
Finished compilation: Thu Feb  3 14:18:14 CET 2005:

make install goes without problems, but the message on top still apears.

any ideas?


Marco Lechner

Institut für Physische Geographie
Uni Freiburg
Werderring 4
79085 Freiburg
Fon 0761 / 203-3548
Mail marco.lechner at geographie.uni-freiburg.de

Höfnerstr. 6
79199 Kirchzarten
Fon 07661 / 907783
Mail marco at marcolechner.de